Home Download
Download JVideo

System Requirements

  • Joomla! 1.5, 2.5, 3.0 or higher
  • PHP 5.1.2 or higher
  • MySQL 4.1.22 or higher
  • cURL module (PHP extension)

Please make sure your system meets or exceeds the minimum system requirements. If you are concerned about meeting the minimum requirements, and you aren't sure how to check, please contact support.

Download JVideo

The latest version of JVideo is 3.0.0 and it was released January 3rd, 2014.

Joomla 3.x

Joomla Component Components
JVideo Component 3.0.0 ZIP (changelog)


Joomla 1.5.x (legacy)

Joomla Component Components
JVideo Component 1.5.2 ZIP (changelog)
 
Joomla! 1.5 Module Modules
Marquee Module 1.5.1 ZIP (requires component version 1.5.1 or higher)
Horizontal List Module 1.5.1 ZIP (requires component version 1.5.1 or higher)
Vertical List Module 1.5.1 ZIP (requires component version 1.5.1 or higher)
 
Joomla Plugin Plugins
Content Plugin 1.5.0 ZIP
Search Plugin 1.5.0 ZIP
 
Joomla Language Pack Language Packs
Language Pack (fr-FR)
Component 1.0 RC3 ZIP
Language Pack (nl-NL)
Component 0.4.x ZIP
 
3rd Party Plugins
JomSocial Plugin 1.5.0 ZIP
Community Builder Plugin 1.5.0 ZIP
JoomlaComment Plugin 1.5.0 ZIP

 

Please report bugs by sending an email to This e-mail address is being protected from spambots. You need JavaScript enabled to view it or use the support forum to help us continue to improve this product.

Questions? Please visit our JVideo support area